Buggies Unlimited Golf Cart Troubleshooting Text Support

G14 Battery keeps draining

G14 Battery keeps draining

Postby Yamahaman52 » Mon Jul 09, 2012 5:41 pm

I have a G14 (1996) I bought a few years ago (2005?). I bought a new marine starting battery for it then. Now, the battery drains after continued use. I have charged and tested the battery and it's good. So, is it the voltage regulator, starter/generator, or something else and how do I test for it?
Yamahaman52
 
Posts: 15
Joined: Sat Apr 17, 2010 12:59 pm
Location: Jackson, Michigan

Re: G14 Battery keeps draining

Postby Yamahaman52 » Mon Jul 16, 2012 8:39 pm

Okay, maybe my cart picked a time when all the experts were on vacation, but I think I have it fixed. I took my charged battery back to camp and put it in the cart. I decided to clean the wires to see if I could identify one coming from the starter/generator and test it's voltage while on high idle. I used a soft wet scrub brush (wires had a lot of dirt and crud on them). Some people may wish to use air compressor. Anyway, during this process I found a wire coming from the generator with a female connector unplugged. After a little more cleaning I found another wire (same color) with a male connector. Yup, I plugged the two wires together and then tested the battery on high idle. It was charging at 14.3 volts. Problem fixed I think! :D
Yamahaman52
 
Posts: 15
Joined: Sat Apr 17, 2010 12:59 pm
Location: Jackson, Michigan


Return to Yamaha Gas

Who is online

Users browsing this forum: No registered users and 3 guests