Buggies Unlimited Golf Cart Troubleshooting Text Support

2000 Yamaha g16 runs great on choke

Moderators: BU_CartGuy, Path Maker, Keyguy, Barry Wilson, BU Employees, Mods

2000 Yamaha g16 runs great on choke

Postby 1funnycar » Wed May 09, 2012 12:21 am

I JUST REBUILT THE MOTOR AND IT RUNS GREAT, NO SMOKE OR LEAKS BUT IT BOGS DOWN WHEN YOU TRY
TO TAKE OFF THEN CATCHES UP BUT IF YOU PULL OUT THE CHOKE IT RUNS LIKE A BEAR. I KNOW IT MUST
BE STARVING FOR FUEL BUT WHY, IT DOES NOT LOAD UP IF YOU RUN IT WITH THE CHOKE OUT OR NO BLACK
SMOKE FROM TOO MUCH FUEL, ANY SUGGESTIONS.
THANKS BRIAN
1funnycar
 
Posts: 2
Joined: Wed May 09, 2012 12:04 am

Re: 2000 Yamaha g16 runs great on choke

Postby Path Maker » Thu May 10, 2012 4:41 pm

Check to make sure your fuel pump is functioning properly and check your vacuum line for leaks.
Path Maker
 
Posts: 429
Joined: Thu May 27, 2010 12:41 pm

Re: 2000 Yamaha g16 runs great on choke

Postby CARTFIXER1 » Thu May 10, 2012 11:08 pm

Clean out the carb and it will run llike a champ again
Owner-CARTFIXER in the Villages Florida. Want your golf car fixed correctly- have a golf car mechanic work on it.
CARTFIXER1
 
Posts: 1097
Joined: Fri May 21, 2010 8:16 pm
Location: The Villages, Florida

Re: 2000 Yamaha g16 runs great on choke

Postby 1funnycar » Sat May 12, 2012 12:12 pm

Hi
You have been very helpful but i have some electrical questions on the g16a
where does the low oil lead (blue wire) coming off the motor attach to
and also there is a black/red wire comming out of the harness buy the generator/starter with a
male end on it where does that go low oil wire or for lighting?
thank you Brian
1funnycar
 
Posts: 2
Joined: Wed May 09, 2012 12:04 am


Return to Yamaha Gas

Who is online

Users browsing this forum: No registered users and 6 guests