Buggies Unlimited Golf Cart Troubleshooting Text Support

93 EZGO gas; uphill sluggish

Moderators: BU_CartGuy, Path Maker, Keyguy, Barry Wilson, BU Employees, Mods

93 EZGO gas; uphill sluggish

Postby rngr195 » Thu Aug 05, 2010 2:27 pm

new to this cart thing. just bought a used 93 ezgo gas powered. new air filter, new belt, new plug, etc. the cart is very sluggish going up hill. i've been told the govornor is keeping it from performing better up hill and to take it off... two questions (1) any harm in taking the govornor off? (2) how do i take off the govonor or adjust it to allow more rpm for going up hills?

the cart "tops out" with the pedal floored. it feels like it could go faster, but just won't. i don't want to race this thing, i just want better performance uphill and maybe a little more top end.
rngr195
 
Posts: 2
Joined: Thu Aug 05, 2010 2:17 pm

Re: 93 EZGO gas; uphill sluggish

Postby micksdrunk » Tue Aug 10, 2010 10:18 am

you should post this ? in the gas forum
one beer deserves another and yet another
micksdrunk
 
Posts: 328
Joined: Wed Apr 07, 2004 1:14 pm
Location: mesatown az

Re: 93 EZGO gas; uphill sluggish

Postby tazassape » Thu Jan 20, 2011 12:29 pm

micksdrunk wrote:you should post this ? in the gas forum



micksdrunk you must of had a few when you answered this one. :mrgreen:
tazassape
 
Posts: 2
Joined: Tue Dec 14, 2010 8:50 am

Re: 93 EZGO gas; uphill sluggish

Postby HotRodCarts » Thu Jan 20, 2011 7:56 pm

The post was move here from the electric forum. :mrgreen:
User avatar
HotRodCarts
 
Posts: 5315
Joined: Thu Nov 04, 2004 10:17 am
Location: Illinois


Return to EZGO Gas

Who is online

Users browsing this forum: No registered users and 7 guests