Buggies Unlimited Golf Cart Troubleshooting Text Support

ezgo textron charger model 23098 1989

Moderators: BU_CartGuy, Path Maker, Keyguy, Barry Wilson, BU Employees, Mods

ezgo textron charger model 23098 1989

Postby muskoka guy » Thu Dec 20, 2012 2:11 am

hey all, just discovered this forum . love the advice. i have a charger and it appears a couple of wires have been unplugged inside. i just got the cart and charger but the previous owner had the top off the charger. he said he hadnt ever charged the cart as he didnt know if the charger worked. he had the cart given to him and he just had it sitting around so he sold it to me. i was wondering if anyone knows where i might find the wiring diagram of the charger. i dont want to plug the wires into the wrong place and wreck it if all it needs is the two wires connected back on. there are two open spots on the back of a small black box near the top. there doesnt appear to be anywhere else for them to plug into. the one wire seems to be a power as it runs from the fuse .it runs to a two into one connection that feeds something else. the other is a single wire and it comes from the charging light. it looks to me like they both should plug into the black box . any help would be appreciated.
muskoka guy
 
Posts: 5
Joined: Thu Dec 20, 2012 1:49 am

Re: ezgo textron charger model 23098 1989

Postby Barry Wilson » Thu Dec 20, 2012 10:58 am

For wiring diagrams, email tech support with a wiring diagram request including Model, Year and Voltage.
User avatar
Barry Wilson
 
Posts: 194
Joined: Tue Mar 10, 2009 3:27 pm
Location: Richmond, Ky

Re: ezgo textron charger model 23098 1989

Postby muskoka guy » Fri Dec 21, 2012 3:00 pm

thanks for the tip i have emailed them but have not gotten a reply yet. looking throught the forums i have read that this black box is a relay. i have read that several people have had problems with the relay and have bypassed it in order to make the charger work but you lose the auto shut off feature. some suggested adding a timer to replace the lack of a shutoff. i am wondering if this is why these two wires were disconnected. am i right with these assumptions. i am trying to charge the cart with my auto charger two batteries at a time but am still getting readings of under 6 volts at each battery. i will continue trickle charging them for a few days and see if they improve. unfortunately the previous owner had the cart given to him and he never had it running and didnt know much about it. i will keep reading and trying. at least the end of the world didnt happen. haha
muskoka guy
 
Posts: 5
Joined: Thu Dec 20, 2012 1:49 am


Return to EZGO Electric

Who is online

Users browsing this forum: usgicollector and 5 guests